tp-link

TP-Link TL-WN722N v3 monitor mode for use with Linux

tp-link

Introduction

Unfortunately TP-Link decided to change the chip in the v3 version of the TL-WN722N that doesn’t support monitor mode out of the box. I came accross a method to enable monitor mode on the v3.

Installing the correct drivers for monitoring mode

First we need to remove the current drivers, clone the modified drivers from GitHub and make sure the correct drivers are loaded on bootup. Follow the commands below:

# Update apt.
sudo apt update
# Install bc.
sudo apt install bc
# Remove the old kernel drivers.
sudo rmmod r8188eu.ko
# git clone the new drivers.
git clone https://github.com/aircrack-ng/rtl8188eus
cd rtl8188eus
sudo -i
# Blacklist the old drivers to make sure they don't get installed again.
echo "blacklist r8188eu" > "/etc/modprobe.d/realtek.conf"
exit
# If you get this error: lib/modules/5.15.0-kali3-amd64/build: No such file or directory. Install the Linux Headers
sudo apt-get install linux-headers-5.15.0-kali3-amd64
make
sudo make install
sudo modprobe 8188eu

Checking monitor mode

After the correct drivers are installed we can enable monitor mode and check the status.

ifconfig wlan0 down
airmon-ng check kill
iwconfig wlan0 mode monitor
ifconfig wlan0 up
iwconfig

Conclusion

The TP-Link TL-WN722N v3 is a great WiFi adapter for use with Linux with these modified drivers. The dongle is easy to use and cheap to buy.

Disclaimer

Always make sure you got explicit permission from the owner of the target that you are testing the WiFi Linux tools on. Not having explicit permissions can get you into serious trouble. Only use these guides for learning purposes and to improve your security.

6 comments

  1. after is did the : echo “blacklist r8188eu” > “/etc/modprobe.d/realtek.conf”. and started ‘make’ this happened:
    └─$ sudo make
    make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/5.15.0-kali3-amd64/build M=/home/voldemort/rtl8188eus modules
    make[1]: *** /lib/modules/5.15.0-kali3-amd64/build: No such file or directory. Stop.
    make: *** [Makefile:2058: modules] Error 2

    pls help me

      1. sudo apt-get install linux-headers-5.15.0-kali3-amd64
        Reading package lists… Done
        Building dependency tree… Done
        Reading state information… Done
        E: Unable to locate package linux-headers-5.15.0-kali3-amd64
        E: Couldn’t find any package by glob ‘linux-headers-5.15.0-kali3-amd64’
        E: Couldn’t find any package by regex ‘linux-headers-5.15.0-kali3-amd64’

        it is unable to find the header

Leave a Reply

Your email address will not be published.